Product Selector

Fusion 5.11
    Fusion 5.11

    Connector Plugins Repository APIFusion Connectors APIs

    Table of Contents

    The Connector Plugins Respository API lists plugins from the built-in plugin repository.

    When you install a connector or plug-in on Fusion 5.x.x, you do not need to supply the .zip file. The installation obtains the .zip file from the repository. Fusion 4.x.x and earlier releases required you to supply the .zip file.

    Examples

    The examples below use the following parameter values:

    Parameter Value

    User

    admin

    Password

    Password123

    Cluster

    http://FUSION_HOST:FUSION_PORT

    Change these values if you are using the example commands.

    Listing plugins

    A plugin’s version and sdkVersion value depends on the connector’s platform version and update history. You might encounter a plugins with very different version values, such as 2.1.0 and 5.2.0. The variance in versioning is expected.
    All plugins
    curl -u USERNAME:PASSWORD {cluster}/connectors/repository
    [ {
      "id" : "lucidworks.fs",
      "version" : "2.1.0",
      "sdkVersion" : "2.0.0",
      "location" : "com/lucidworks/connector/plugins/lucidworks.connector.fs/2.1.0/lucidworks.connector.fs-2.1.0.zip"
    },
    {
      "id" : "lucid.twitter-search",
      "version" : "5.2.0",
      "sdkVersion" : "5.2.0",
      "location" : "com/lucidworks/connector/plugins/lucid.twitter-search/5.2.0/lucid.twitter-search-5.2.0.zip"
    },
    {
      ...
    } ]
    Specific plugin
    curl -u USERNAME:PASSWORD {cluster}/connectors/repository?name=lucidworks.fs
    [ {
      "id" : "lucidworks.fs",
      "version" : "2.1.0",
      "sdkVersion" : "2.0.0",
      "location" : "com/lucidworks/connector/plugins/lucidworks.connector.fs/2.1.0/lucidworks.connector.fs-2.1.0.zip"
    } ]
    Invalid plugin

    If you attempt to list an invalid plugin name, the output will appear as follows:

    curl -u USERNAME:PASSWORD {cluster}/connectors/repository?name=lucidworks.asd
    [ ]