Requirements

This topic explains software requirements for using Lucidworks Managed Search.

On-premises software

The only on-premises software needed to use Managed Search applications is a web browser.

You can also write HTTP client applications that call Managed Search APIs.

Cloud provider

The supported cloud provider is Google Cloud Platform. You don’t need to concern yourself with the cloud provider.

Solr version

The Solr version in Managed Search is compatible with Solr 8.1.

Lucidworks maintains a private fork of Lucene/Solr from which we create our images. We build from the latest supported release branch so that we are as close to the open source release as possible. This lets us move quickly, and backport fixes and enhancements without waiting for an open source release.

Web browser

Mission Control and the Cluster Manager are only supported with these web browsers:

  • Chrome latest version

  • Firefox latest version and latest Extended Support Release (ESR)

  • Internet Explorer 11

API clients

Any HTTP client with a valid OAuth2 access token can access Managed Search APIs.

Safe storage and use of authentication credentials

Lucidworks provides you with authentication credentials. Store them securely and never transmit them as plain text.